[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

nForce2 ethernet not working after dist-upgrade to lenny


Saturday I did a dist-upgrade from etch (2.6.18 kernel) to lenny, it appeared successful, even after several reboots, however as of today, I have no network connection. (the network itself is fine, this is sent from another box on the same switch)

The debian box in question is a AMD with an Asus A7N8X board and kernel 2.6.26 (from dist-upgrade)

[dwright@debian dwright]$ dmesg
[  131.968012] eth2: no IPv6 routers present
 (now obsolete) site-local IPv6 
... (truncated)
Mar  8 12:36:10 debian kernel: [    3.712572] forcedeth: Reverse Engineered nForce ethernet driver. Version 0.61.
Mar  8 12:36:10 debian kernel: [    3.713135] ACPI: PCI Interrupt Link [APCH] enabled at IRQ 22
Mar  8 12:36:10 debian kernel: [    3.713198] ACPI: PCI Interrupt 0000:00:04.0[A] -> Link [APCH] -> GSI 22 (level, high) -> IRQ 22
Mar  8 12:36:10 debian kernel: [    4.232807] forcedeth 0000:00:04.0: ifname eth0, PHY OUI 0x732 @ 1, addr 00:0c:6e:d9:74:8d
Mar  8 12:36:10 debian kernel: [    4.232888] forcedeth 0000:00:04.0: timirq lnktim desc-v1
... (truncated)
Mar  8 12:36:10 debian kernel: [    4.382647] udev: renamed network interface eth1 to eth2
Mar  8 12:36:10 debian kernel: [    4.426656] udev: renamed network interface eth0_rename to eth1
... (truncated)
Mar  8 12:36:10 debian kernel: [   54.036631] eth2:  setting full-duplex.

[dwright@debian dwright]$ sudo /sbin/ifconfig eth2
eth2      Link encap:Ethernet  HWaddr 00:26:54:13:be:fb  
          inet6 addr: fe80::226:54ff:fe13:befb/64 Scope:Link
          RX packets:267 errors:0 dropped:0 overruns:1 frame:0
          TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:52583 (51.3 KiB)  TX bytes:7981 (7.7 KiB)
          Interrupt:20 Base address:0xe000 

[dwright@debian dwright]$ sudo lspci -v
00:04.0 Ethernet controller: nVidia Corporation nForce2 Ethernet Controller (rev a1)
	Subsystem: ASUSTeK Computer Inc. A7N8X Mainboard onboard nForce2 Ethernet
	Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
	Memory at e2086000 (32-bit, non-prefetchable) [size=4K]
	I/O ports at e400 [size=8]
	Capabilities: [44] Power Management version 2
	Kernel driver in use: forcedeth
	Kernel modules: forcedeth

(there is also a 3Com Corporation 3C920B-EMB, which never worked)

lsmod shows the forcedeth but shows it is unused, i.e. 0

Again, this is after a 'straight' sudo dist-upgrade.



Reply to: