[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


Debian Lenny, fresh install
I uncomment these lines in: /etc/dhcp3/dhclient.conf

send host-name "mypc"
send dhcp-client-identifier "foo"

I install local DNS cache [with OpenDNS]
apt-get install dnsmasq
echo "prepend domain-name-servers,,;" >> /etc/dhcp3/dhclient.conf
sed -i s/'#listen-address='/'listen-address='/g /etc/dnsmasq.conf

/etc/init.d/dnsmasq restart
/etc/init.d/networking restart

four question's :S
1 - After this, OpenDNS is working, I mean, if I type "google.comsaldkfjlskdj" in the webbrowser, it pop's out an opendns page. Ok [is it Ok?].
2 - I "dig google.com", it say's "SERVER:", Ok [is it Ok?].

But the most important question is:
3 - If I go to another computer [same subnet], and type: "ping mypc", it say's: "ping: unknown host: mypc" - after waiting for a while, rebooting, it still say's the same :( When I ping it with IP, it works, but not with hostname :(

Could someone help me with this three questions?

ps.: I use iptables, but the problem is the same, when I iptables -P INPUT ACCEPT; iptables -P OUTPUT ACCEPT; iptables -P FORWARD ACCEPT; iptables -F; iptables -X

My ....iptables script....[not sure, it's 100% :D :S - just a regular homepc, with a router]

ps2.: I tried this doc, but I still can't "ping mypc" from another pc
4 - With this iptables script, I can only download torrents when I "iptables -P OUTPUT ACCEPT", so I don't know that can I uplodad using APT-P2P?

I tried adding the lines to the script, but torrent still doesn't work:
$IPTABLES -A INPUT -p tcp --dport 6881 -j ACCEPT
$IPTABLES -A INPUT -p udp --dport 6881 -j ACCEPT

ps3.: The netfilter mailing list is "offline" - I can't reach it :( sorry for posting my iptables script here, but no'one can check it in my environment :( or say it it has a error
ps4.: In my "/etc/hosts" file, there is a line with " mypc"

Thank you for you're patience reading this! :S
Regards & Thank you!

Reply to: