[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [SOLVED]Segmentation fault when stating aptitude

On Tue, Mar 03, 2009 at 08:27:02AM +0000, Bob Cox wrote:

> > deryj@gontran:/var/cache/apt$ sudo aptitude update
> > Hit http://security.debian.org etch/updates/main Sources
> > Hit http://security.debian.org etch/updates/contrib Sources
> > Ign http://ftp.uk.debian.org etch/contrib Packages/DiffIndex
> > Hit http://ftp.uk.debian.org etch/main Packages
> > Hit http://ftp.uk.debian.org etch/contrib Packages
> > Get:3 http://http.us.debian.org stable Release.gpg [386B]
> > Hit http://http.us.debian.org stable Release
> > Ign http://http.us.debian.org stable/main Packages/DiffIndex
> > Ign http://http.us.debian.org stable/contrib Packages/DiffIndex
> > Ign http://http.us.debian.org stable/non-free Packages/DiffIndex
> > Hit http://http.us.debian.org stable/main Packages
> > Hit http://http.us.debian.org stable/contrib Packages
> > Hit http://http.us.debian.org stable/non-free Packages
> I notice that you are getting updates and security updates for etch but
> also updates for stable (lenny) with no corresponding security updates.
> Are you intentionally mixing etch and lenny using pinning or a
> "APT::Default-Release" setting?  Just a thought.

Hi list,

Problem solved! 

Explanation: My intentions were not to mix Lenny and Etch together. 
I created sources.list a long time ago and never paid attention to its
content since it worked. --> It never caused problem when Etch was stable. 
I guess I was lucky. My luck ran out when Lenny became stable (and Etch 
became old stable).

So I cleaned up sources.list. It solved the problem.

Thank you Bob

Reply to: