[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[solved] Re: grub locked

On Fri, 27 Feb 2009 18:46:12 -0500
Andrew Reid <reidac@bellatlantic.net> wrote:

> On Friday 27 February 2009 02:18:26 Celejar wrote:
> > Hi,
> >
> > I was just greatly disturbed to find that I am unable to edit my grub
> > command lines (with 'e') or to get a command shell (with 'c').  This
> > used to work, although I can't remember the last time I tried it.
> > Googling indicates that this is what happens when grub is locked, with
> > 'password' command in menu.lst, but I have not done that!  What could
> > be causing this?  I can still select a kernel choice with the cursor
> > keys and the carriage return.
>   Well, that is precisely the locked behavior.
>   I can think of two things to try.


>   Secondly, if this is indeed the right menu.lst, try setting
> a password, and see if it works, and then unsetting it.  

So I tried this, and indeed, I now saw the 'press p for password to
unlock' message, instead of the 'press e to edit or c for the shell'
message.  I pressed 'p', but once again nothing happened. I was
momentarily stumped, but the answer presently hit me in a flash:  In
both console and X, I use the Dvorak keymapping, so as far as *I'm*
concerned, left-index-finger-up is 'p', and so on, but of course, grub
is running before either of those keymaps are loaded, so as far as *its*
concerned, I've been pressing 'r' (and previously, 'd' and 'i'), which
it very properly ignores ...

*smacks himself on head*

Thanks very much for the help!

mailmin.sourceforge.net - remote access via secure (OpenPGP) email
ssuds.sourceforge.net - A Simple Sudoku Solver and Generator

Reply to: