[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem with CUPS

On Fri, Jan 02, 2009 at 11:35:43AM -0800, Zach wrote:
> On Jan 1, 9:10 am, "Douglas A. Tutty" <dtu...@vianet.ca> wrote:
> > On Thu, Jan 01, 2009 at 05:20:20AM -0800, Zach wrote:
> > > On Dec 31 2008, 7:10 pm, Bob McGowan <bob_mcgo...@symantec.com> wrote:
> > > I tried web interface as root and normal user, I tried running gnome-
> > > cups-manager, I even tried running lpadmin. It either says in the cups
> > > log file I am not authorized or I get that weird "entity too large"
> > > message. Ugh this is maddening. Is there a non-cups method to get
> > > printing setup I could try?
> >
> > Non-cups means using a different print spooler.  e.g. lpd or LPRng.  The
> > question is setting up the print filter.  You can try apsfilter.
> Thanks Doug since I am desperate I will try that. I wish I could
> understand why I keep getting these baffling errors in cups. I have
> the correct drivers so it *should* work. Sigh.

The "drivers" are likely ppd files for use of cups-type stuff.  The only
cups filter in foomatic-printfilters.  Note that you can use foomatic
with lpd or lprng.  If your problem is the spooling and not the
filtering, that may be the way to go.

At least with raw lpd, you should be able to print plain text to the
printer to verify that spooling works, then work on getting proper


Reply to: