[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Grub can't boot hda1 (vfat/diagnostics), need to do something from DOS? - SOLVED

On Thu, Jan 01, 2009 at 09:56:10AM +0100, Sven Joachim wrote:
> On 2009-01-01 09:46 +0100, Joel Roth wrote:
> > On Thu, Jan 01, 2009 at 09:25:55AM +0100, Sven Joachim wrote:
> >> You must install the DOS bootloader with the "sys" command.
> >
> > I believe the DOS bootloader will simply overwrite GRUB,
> > which resides in the boot sector of the disk, having
> > no effect on the properties of the first partition.
> No, it won't.  The sys command only changes the bootsector of the
> partition, it does not change the MBR.
> Sven

Thank you.  That was the missing step.  I copied sys.com (which
wasn't in the diagnostics partition) from my dosemu/freedos directory
to an old DOS floppy, which also didn't have it.  I then booted the
machine from the DOS floppy, and did this:

>copy sys.com c:
>sys c:

After a lot of verbosity about not copying kernel.sys and command.com,
which were already there, and a lot or trepidation fearing that the new
disk was now unbootable, I did the CTL-ALT-DEL thing and the grub screen
came up.  Selecting the Dell Diagnostics entry brought up the
diagnostics main screen.  Problem solved.  Thanks again and happy new


Reply to: