[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem with CUPS

On Wed, Dec 31, 2008 at 04:04:23PM -0800, Bob McGowan wrote:
> On Wed, 2008-12-31 at 16:42 -0500, Zach Uram wrote:
> > I am using http://localhost:631/admin and click Add Printer and select
> > HP960C and the hplip driver then when I apply it says: 413 Request
> > Entity Too Large
> > 
> > I am running firefox as root so I don't know why it is failing. I also
> > tried running gnome-cups-manager as root which calls gnome-cups-add
> > and it says:
> <snip>
> Not sure what that would mean, so I can't provide any help there.
> But, when I run the browser based GUI, I do it as me, not root.  Then,
> when I do something that requires root permission to perform, the GUI
> pops up a logine box, I enter 'root' and the root password.
> Could be it's not working for you because the root login permissions let
> you run things, but the permissions aren't correctly propagated to the
> Apache server side?

It should be sufficient to be a member of group lpadmin; there's no need
to be root to manage CUPS, in my experience.


Ken Irving

Reply to: