[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: No sound on a Thinkpad T61 w/ ALSA and AS1984 sound card (redux)

I'm going to amalgamate all of your thoughts into a single email for
simplicity - not sure if that's correct protocol or not, so let me
know if it would be better if I replied to each email individually.
Thanks everyone for all of the help!

> do you need the OSS stuff?  might it be that something is
> grabbing the resource there and hogging it?

I have no idea - honestly, I just went with the out-of-the-box debian
lenny configuration.

> My sound, however, *does* work.  The Gnome volume applet sees
> it as "HDA Intel (Alsa mixer)" just like yours.  Make sure
> you're controlling the right device (File | Change Device)

According to alsamixer and the xfce volume control applet, I'm
controlling the right sound card (they report HDA Intel and HDA Intel
Analog Devices AD1984, respectively).

> Have you tried other kernels when booting your Lenny, just to check that your
> current sound problems are the same when booting other kernels.

I installed linux-image-2.6.24-etchnhalf.1-686 to check, and still no
sound. Historically, however (as in, before I started having problems
a few days ago), I've had sound work on a 2.6.24 kernel before.

> Also looking at the ALSA-configuration.txt file for the 1.0.16 alsa driver,
> and later versions, the AD1984 codec lists 3 model options, as below.
> AD1984
>   basic  default configuration
>   thinkpad Lenovo Thinkpad T61/X61
>   dell  Dell T3400
> If you havn't already done so, it may be worth adding the following line
> to /etc/modprobe.d/alsa-base.
> options snd-hda-intel model=thinkpad
> Reboot after doing this. You can restart alsa, but a reboot starts from
> scratch, so may be the easier option.

I didn't have this in my alsa-base file, and I've now added it. Still
no sound, though.

> You may find that opening alsamixer as user on the CLI (Gnomes terminal, or
> KDE's Konsole), may show more controls, which may need to be unmuted (M key
> to mute/unmute), or additional sliders that need to be pushed up to get sound
> output.

Nothing that I can see, unfortunately. Master is at full, headphones
reads 00, PCM is at full, speaker reads 00. IEC958 is off, but turning
it on doesn't seem to change anything. All the mics are muted.

> I am puzzled that your lsmod shows the module, snd-hdsnd-hda-intel. I can't
> find that module anywhere, but apparently in your case it is loaded, and 2
> things are using it. Try the commands below, and post the output, to see what
> if anything is using the sound, and may be preventing your sounds working.
> lsof -n | grep /dev/dsp
> lsof | grep /dev/snd

Gah! I must've messed up the copy/paste or something. Thanks so much
for your diligence. Here's what it should have read:

$ lsmod | grep snd_hda_intel
snd_hda_intel         331032  2
snd_pcm                62820  2 snd_pcm_oss,snd_hda_intel
snd_page_alloc          7496  2 snd_hda_intel,snd_pcm
snd_hwdep               6308  1 snd_hda_intel
snd                    46724  14

And here are the other commands (lsof -n | grep /dev/dsp returns nothing):

$ lsof | grep /dev/snd
xfce-mcs- 3393 kylebarbour    5u      CHR      116,0             5678
xfce4-mix 3410 kylebarbour    6u      CHR      116,0             5678
firefox-b 3627 kylebarbour  mem       CHR     116,16             5659
firefox-b 3627 kylebarbour   62r      CHR     116,33             5301
firefox-b 3627 kylebarbour   63u      CHR     116,16             5659


Reply to: