[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: usb discovery fails on initial boot

Florian Kulzer wrote:

It would be interesting to see if the system recognizes the first USB
stick when you remove it and plug it in again. You should run

tail -fn0 /var/log/syslog

before you unplug it, then plug it in again and wait for at least thirty
seconds.  (Press CTRL-C to end the syslog watch.) Post the output that
you get, it might help to see how the system reacts to the unplug and to
the "replug" event.

Looking at the syslog when plugging and unplugging was most interesting. It seems the stick or the ports have a connection problem. My PC has 2 USB ports on the front and 4 on the back. I was using a rear port for the permanently plugged in stick as the front ports are more exposed to accidentally knocking. When I plugged it into the front the USB was set up ok but in the back ports I got a series of error messages similar to the ones in the bootup syslog. One line read:

"Nov 16 19:59:50 localhost kernel: hub 5-0:1.0: Cannot enable port 4. Maybe the USB cable is bad?"

When I tried a different stick in the back the stick worked ok. However the "faulty" stick worked ok in the front ports, so this stick and the rear ports don't get on too well.

I'm sure this solves my problem - I'll start by getting a new stick for the back and hope it connects ok (the different one I tried is not mine). Thanks for all your help in tracking this down. It's a bit odd that the faulty stick didn't work in ANY of the rear 4 slots but did in the front, whereas a different stick did work ok in the rear. Still not something I'm going to spend much time on figuring out.

Again many thanks Florian.

Best regards

Reply to: