[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

kde: can't right click and get context sensitive menu, iceweasel drop down menus dont drop


I am only having this trouble on only one of my many systems running sid. It
started a while ago. It only is a problem if I run X directly. If I run
via vncserve there  is no problem.

I run KDE. 

I noticed first that when I clicked on any of the
_File _Edit _View _History menus on top of Iceweasel window, it did not drop
down. I had to do alt-F or alt-E or alt_V in order to get the window to 
be activated. At that point I could scroll down with the arrow to my selection.

Then I noticed similarly that the right mouse button will not give context
menu on desktop. Similarly I cannot add icons to the panel at bottom of screen.

Then I noticed that I similarly could only select the printer in kprinter
dialog via the down arrow button - mouse would not work.

All mouse works fine on same machine if I log in via the vncviewer and 
vncserver. All three things- right context button, panel icon setup, iceweasel
all work fine.

It is not something messed up with the user. If I set up a new user, after
upgrading to latest sid (this problem persists upon multiple sid
upgrade cycles), I still have the problem.

If I try Gnome:

If I set up and use Gnome, then there  is no such problem with Gnome itself
-ie I do right click I get the menu, I can right click on the panel at top
however still same problem with Iceweasel. However !!! I still have
the problem with the Iceweasel menus not coming down when clicked. Moreover
and this is the most bizarre thing. On gnome I have trouble when I use
vncviewer - ie the right clicks dont work, even though they
worked on the X when I sit at the console.

Any ideas???

Very odd behavior and puzzling!!


Reply to: