[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: what linux/limit.h is needed for backporting cups from lenny to etch?

On Tue, Oct 14, 2008 at 06:57:56AM -0500, Hugo Vanwoerkom wrote:
> Hans Ekbrand wrote:
> >Hi list!
> >
> >I was trying to backport libcups2-dev from lenny to etch when I met
> >with the following error (from config.log)
> >
> <snip>
> >/usr/include/bits/local_lim.h:36:26: error: linux/limits.h: No such file 
> >or directory
> <snip>
> >
> >How do I get around this?
> >
> >I did try to build cups again after having installed
> >linux-headers-2.6.18-6-486, since linux/limit.h exist in that package,
> >but that didn't help :-(
> >
> What error did you get then? Because limits.h then existed.

I got the same error. Which made me think, that I had to help the
build process to find linux/limit.h. Even though I have read for quite
some time ago, that in debian you should need to tamper with symlinks
for kernel-headers, I did just that.

# cd /usr/include/linux
# ln -s /usr/src/linux-headers-2.6.18-6-486/include/linux/limits.h

Tried to build again, and this time the build process got longer and
bailed out with an other error:

Making all in cups...
make[2]: Entering directory `/root/cups-1.3.8/cups'
Compiling adminutil.c...
In file included from /usr/include/sys/socket.h:35,
                 from http.h:43,
                 from ipp.h:26,
                 from cups.h:32,
                 from adminutil.h:29,
                 from adminutil.c:36:
/usr/include/bits/socket.h:304:24: error: asm/socket.h: No such file or directory
In file included from /usr/include/errno.h:36,
                 from adminutil.c:39:
/usr/include/bits/errno.h:25:26: error: linux/errno.h: No such file or directory
In file included from /usr/include/signal.h:333,
                 from /usr/include/sys/wait.h:30,
                 from adminutil.c:45:
/usr/include/bits/sigcontext.h:28:29: error: asm/sigcontext.h: No such file or directory
make[2]: *** [adminutil.o] Error 1

This time asm/socket.h is not on my system, but many very similar files do exist here:

$ find /usr/include -iname socket.h

but not asm/socket.h

Rather than continuing to manually hack around each the compilation
path/problem, I would like to understand what is wrong with my system.

Note that I use Debian version 4.0
Linux amin 2.6.18-4-486 #1 Mon Mar 26 16:39:10 UTC 2007 i586 GNU/Linux
Hans Ekbrand (http://sociologi.cjb.net) <hans@sociologi.cjb.net>
GPG Fingerprint: 1408 C8D5 1E7D 4C9C C27E 014F 7C2C 872A 7050 614E

Attachment: signature.asc
Description: Digital signature

Reply to: