[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Music/Audio CDROMs, DVDs, & Etch kernel Security Update.

The following is a response which I received off-list. With
permission, I have pasted it below so that it gets recorded && within
its rightful thread.


> Hi DB,
> I have this very same issue as you wonderfully described on the Debian


(By necessity, the following makes assumptions about your
experience/knowledge.  If I over- or under-estimate, please forgive

> mailing lists:
> http://lists.debian.org/debian-user/2008/09/msg01696.html
> I can watch DVD, burn to CD, play CD mp3, etc. etc., but I just
> *cannot* play any audio CD's at all (basically it appears as if I have
> no disc in the CD at all).
> Also, as you state, cdparanoia is the *only* application that can see
> the audio CD to rip.
> Did you ever find out the kernel configuration that is the cause of
> this - I am pulling my hair out here.

Honestly, I did not, and do not, have the time to debug this; I was
looking for only a work-around. 
>From past experience, and observations over a few days of testing, I
ended up suspecting the kernel. So I simply tried a new kernel. 

> BTW, Slackware 12, kernel

Hmmm! is exactly what worked for us. It was a generic build,
and so it took its configuration from the running kernel. (And I must
say that I am surprised that Slackware would have such a recent

If you want, you can send me your /boot/config to look at. (Don't post
it here.)

> I hope you can help :-)

Honestly, my advice would be to try a few off-the-shelf kernels ie any
packaged kernels which Slackware provides. This would be the least
painful approach.  Even if you don't wish to keep those kernels
running, it would at least confirm that a work-around exists via the

Or, if you are not using a Slackware-bundled kernel, then download
another kernel from kernel.org and build it. Keep things as generic as
possible ie try not to change the defaults.

If the above does not work out, and no-one else offers a better clue,
then come back and look at the stuff below.


(I have assumed that you've done your google searches and have ruled
out all the generic culprits littered everywhere: file and group
permissions, regions, installing decss, or installing codecs, etc.
Yes, the last 3 don't apply to you.)

More painful approaches include the following, though none is

- trying a live CD. Hopefully, this won't necessitate a second drive
  for your audio CDROM! ;-)

- booting from a USB key. Then you can try your audio CDROMs;

- building the relevant libraries and utilities from source. This
  would give you the very latest versions, and you could enable debug
  Note that I had two symptoms: in audio CDROMs, and in video DVDs.
  Hence, the libraries were different. However, almost nothing had
  changed between the Before and After. Furthermore, in one or two
  tests, I saw the ioctl CDROMREADTOCHDR as being attempted for both
  media. However, AFAIK, no relevant library had changed _but_ that
  the kernel had; hence my focus on the kernel side of the system call
  (Other readers, note: I've done years of firmware work; I don't
  have the time to elaborate on all my thinking and the various
  possibilities. So don't bark back from behind the safety of a

- custom kernel builds. I.e. toggling various options in the kernel
  build until one works;

- remote debugging the kernel from a second box! ;-)

For the record, I am not at all implying that there is a bug in the
kernel. Not even in its build configurations. Not even in the
libraries. Some of the utilities rely on lower-level utilities, AFAIK;
so that is yet another possibility. If I really wanted to get to the
bottom of this, I'd start with the latter or with the kernel build

Note that debian (and perhaps other distros) has forked off the CDROM
work of Jorg Schilling. So some things may be in flux!

Reply to: