[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Aptitude hangs machine -- problem solved

Hash: SHA1

Daniel Burrows wrote:
> On Thu, Aug 14, 2008 at 11:00:11AM -0400, Ken Heard <ken@heard.name> was heard to say:
>> I recently installed in a new Lenovo ThinkPad R61 Lenny using the Lenny
>> Beta2 installer.  The installation went -- as far as I could see -- as
>> it should have.
>> Soon after installation I wanted to upgrade the installed packages.
>> First I updated /etc/apt/sources.list, including adding to it
>> debian-volatile so that I could install the clamav set of anti-virus
>> packages and get the periodic updates to tzdata. Then I ran (as root)
>> "aptitude update", followed by "aptitude upgrade".  It downloaded some
>> 33 package upgrades, including a new kernel (2.6.25-2-686 to replace
>> 2.6.24) and tzdata.
>> The package setup only got as far as tzdata, when the machine hung.  To
>> get the machine going again I had to turn it off using the on/off button
>> and do a cold boot without a proper shutdown.
>> After rebooting I ran aptitude again.  It returned the message that
>> aptitude had been interrupted, and to get it running again I had to run
>> "dpkg --reconfigure -a".  I tried to do so several times; each time it
>> tried to set up tzdata, only getting as far as to say what the current
>> time zone is before hanging up the machine.
>   After it shows you your current time zone, it runs "date".  Does
> running that command at the prompt crash the machine for you?
>   Daniel

Daniel, the problem was indeed the "date" command.  Previously I had
wanted to reformat the output of that command.  To do so I created a
script file with the same name.  Since I had not anticipated use of that
script file inside of another I did not set it up for such use.
Consequently when the tzdata setup ran date, the setup hung.

To solve the problem I created an alias for date with my desired format.
 After doing so I ran once again "dpkg --reconfigure -a", this time

Thanks for the tip.


Ken Heard

Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


Reply to: