[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Aptitude hangs machine

I recently installed in a new Lenovo ThinkPad R61 Lenny using the Lenny Beta2 installer. The installation went -- as far as I could see -- as it should have.

Soon after installation I wanted to upgrade the installed packages. First I updated /etc/apt/sources.list, including adding to it debian-volatile so that I could install the clamav set of anti-virus packages and get the periodic updates to tzdata. Then I ran (as root) "aptitude update", followed by "aptitude upgrade". It downloaded some 33 package upgrades, including a new kernel (2.6.25-2-686 to replace 2.6.24) and tzdata.

The package setup only got as far as tzdata, when the machine hung. To get the machine going again I had to turn it off using the on/off button and do a cold boot without a proper shutdown.

After rebooting I ran aptitude again. It returned the message that aptitude had been interrupted, and to get it running again I had to run "dpkg --reconfigure -a". I tried to do so several times; each time it tried to set up tzdata, only getting as far as to say what the current time zone is before hanging up the machine.

I must say that upgrading tzdata has always caused me trouble; it was never set up on the first attempt, but on all other of my machines running "dpkg --reconfigure -a" was always successfull. On this laptop however I have been unable to achieve success.

Because of this lack of success, I am unable to upgrade or install any packages in this laptop. Is there a way to get out of this catch-22 situation, and consequently upgrade tzdata successfully, and upgrade and install other packages?

Ken Heard

Reply to: