[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installing Canon LBP2900 printer on Lenny

I have Canon i-SENSYS LBP2900 laser printer. It works good under WinXP SP2.

Today I decided to configure it under Debian Lenny. On Canon's website I have found necessary drivers:
From there you can download CAPTDRV160.tar.gz archive which has readme, manual and driver itself in .rpm & .deb formats.
There are packages for Debian:
cndrvcups-common_1.60-1_i386.deb, cndrvcups-capt_1.60-1_i386.deb

I was following the detailed installation instructions (from Canon), which is in "doc/guide-capt-1.6xe.tar.gz" file of total archive.

First of all I installed "cups" package (with dependencies), "ghostscript" package had been already installed. Then I installed two afore-mentioned .deb-packages from Canon. Next I restarted CUPS using "# /etc/init.d/cups restart" command. Then I registered printer as "canon2900" using "/usr/sbin/lpadmin -p canon2900 -m CNCUPSLBP2900CAPTK.ppd -v ccp:/var/ccpd/fifo0 -E" command (as I understood it simply copies .ppd-file for concrete printer model from /usr/share/cups/model/ to /etc/cups/ppd/). Next I registered my printer in ccpd-daemon's config file using "/usr/sbin/ccpdadmin -p canon2900 -o /dev/usb/lp0" command (as I understood printer's driver must connect to concrete usb-interface there). Then I started ccpd-daemon using "# /etc/init.d/ccpd start" command and hoped that printer will become to work.

Canon gives "cngplp" utility to configure printer and to print from file. "$ cngplp -p temp/1.ps" command produced (in KDE) window for page range indication, paper settings etc (similarly as under MS Windows) and after I pressed "Print" button in this window it was ought to print but I got the following error:

cngplp: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.

During all these procedures printer itself has given no visible signal!

Then I tried to use printer installation instruction from

Many things from it has already become unnecessary because Canon gives .deb-packages now. In particular, I have replaced "/etc/init.d/ccpd" script to one given on this website (in Step 5). I have also used "update-rc.d ccpd defaults 20" command for automatically start of ccpd-daemon while system booting.

After OS rebooting nothing changed. But I tried "$ captstatusui -P canon2900 &". It opened a window (print monitor) and select "Options/Cleaning" menu item. Then printer responded! (for the first time). It began to slowly press in lines (without toner) on the paper. But "$ cngplp -p temp/1.ps" command produces such error as before.

My hardware:
     mb: 8RDA3I rev 3.3
         northbridge: nForce 2 Ultra
         southbridge: MCP
     cpu: Sempron 2200 (k7)
     printer: Canon i-SENSYS LBP2900 (interface: usb)

My software:
     Debian Lenny
     kernel: Linux 2.6.25-2-686
     x11: xserver-xorg 1:7.3+14
     kde 3.5: kde-core 5:48
     cups 1.3.7-9
     canon drivers: 1.60-1

Reply to: