[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: NFS is working again, but problem not solved.

On Mon, 04 Aug 2008 14:41:04 +1000, Alex Samad wrote:

> On Mon, Aug 04, 2008 at 02:27:01AM +0000, Hendrik Boom wrote:
>> On Sun, 03 Aug 2008 22:15:25 -0400, Andrew Reid wrote:
> [snip]
>> /usr,sync,no_root_squash,map_identity)
> what about map_identity ? you using nis/ldap ?

Not that I'm aware of.  Not unless Debian introduced it without telling 
me.  They don't sound like services I could be using without being aware 
of it, but ... is there an easy way of telling whether they are operating?

Incidentally, while the NFS outage happened, I set up shadow (the NFS 
client above) to serve one of its partitions to another machine on the 
net, and that worked, so it looks as if the problem was specific to april 
as NFS server (or shadow as NFS client).  Now what's different about 
april is:
	It's an AMD64 running in 64-bit mode.
	It is running etch/stable.  All the others are running lenny.
	The partition being shared out is an LLVM partition on RAID1.
Is it conceivable that the kernel NFS server in etch fails to start up 
without DNS being available to interpret the configuration file, even if 
no domain names appear in it?

If there's any chance of it, I might be able to reproduce the situation 
that obtained on Saturday on by shutting off the DSL modem and serving 
NFS from another machine that's dual-boot etch and lenny.  It that works 
(i.e.failes properly) it will probably be an etch-specific problem, and 
the looming upgrade of our server to lenny will fix the problem.

-- hendrik

Reply to: