[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: NFS is working again, but problem not solved.

On Sun, 03 Aug 2008 11:42:04 +0000, Hendrik Boom wrote:

> At home we have a file server (called april), which provides a central
> filesystem (called /farhome) containing everyone's home directory.
> It's been working fine for years, until yesterday,
> Suddenly one of our machines (called shadow) cannot mount /farhome, ans
> instead gets mount timeouts.

And now it's working again. See below.

> Another machine (called lovesong), which has /farhome slready mounted, just
> keeps working.
> Frankly, I'm afraid to reboot lovesong in case we end up havein go run all
> our programs directly on the file server.
> As far as I know, nothing has changed in the systen set-up.  WHich
> probably just shows how little I know.  I have been doing regular security
> updates on the server, of course; I don't know when the most recent one
> was.  april runs etch, with kernel 2.6.18-6-amd64.  I tried rebooting april
> into an older kernel 2.6.18-3-amd64. It didn't help.
> I can ping esily between the two boxes.  I can ssh from shadow to april,
> too, so connectivity shouldn't be a problem.  The permissions in
> /etc/exports are the same as always, and identify the machines by IP
> number, so DNS failure shouldn't be relevant.
> Does anyone have deas how to track this down?

While mfs mounting wasn't working, our LAN was disconnected from the wider
internet.  Although all the machines in question could talk to each
other, the DSL link to the rest of the world was down because of ISP
failure. Now it's up again, and NFS mounting works fine again.

So why does nfs need access to the wider internet?


Reply to: