[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cannot find /dev/parport0 - ANY SUGGESTIONS?



On Thu, Jul 17, 2008 at 12:35:23PM -0700, Account for Debian group mail wrote:
> 
> 
>  Hello Again,
> 
>  I just upgraded our print server/samba machine from sarge to etch.
> 
>  In the /var/log/dmesg file i see:
> 
>  parport: PnPBIOS parport detected.
>  parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
>  parport0: Printer, Hewlett-Packard HP LaserJet 6MP
> 
>  This looks correct.
> 
> 
>  In the /etc/printcap file I have:
> 
>  lp|Our Printer:\
>          :lp=/dev/parport0:\
>          :sd=/var/spool/lpd/lp:\
>          :af=/var/log/lp-acct:\
>          :lf=/var/log/lp-errs:\
>          :pl#66:\
>          :pw#80:\
>          :pc#150:\
>          :mx#0:\
>          :sh:
> 
>  When I do a "checkpc" I get:
> 
>  Warning - lp: cannot stat lp device '/dev/parport0' - No such file or directory
> 
> 
>  What is it that I'm doing wrong?

well first, you are expecting help in approximately two and a half
hours from an all volunteer list... and yelling when you don't get
it. 

I don't know much about parallel ports anymore, but the first thing I
would do is grep for "parport" in /var/log/syslog in case it shows up
somewhere else. It's possible that udev is doing something tricky like
moving it to a different node. Also I would ls /dev and look through that
for other things that might be a parport. 

hth...

A

Attachment: signature.asc
Description: Digital signature


Reply to: