[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SATA drive problems in LENNY...

Thanks, Ron! The solution was noapic as a kernel parameter though. Mark 
Allums' shot in the dark held the key. Then I tried to transfer my system 
from the old 8.6G ide disk to the new 500G sata disk, following 
instructions you seem to have gotten on another occasion: dd and 
resize2fs. dd worked, resize2fs failed miserably... So right now I am 
re-installing the system happily on the 500G sata disk. 

Hint for the debian installation disk managers: Took me some time to 
figure out how to add a boot parameter to the installation kernel on the 
netinstall CD. Should be easy to include a menu item that gives the 
standard for the minimum information that has to be entered at the boot 
boot: /install.amd/vmlinuz initrd=/install.amd/initrd.gz 
and leaves a blinking cursor right there to add your own boot option (e.g. 
noapic...) or press return for normal installation boot (as you would get 
with the first menu item, install). Just a thought. Would have made my 
life much easier and saved me one doomed boot to see what install is 
booting... Not evident that a newbie would have figured this out as a way 
to get at the information. 

Thanks again, all you guys! Hope this makes it into the thread for future 

Best, a happy Kai

On Tue, 15 Jul 2008, Ron Johnson wrote:

> Hash: SHA1
> On 07/15/08 00:53, Kai Martens wrote:
> > Hi there,
> > 
> > While upgrading to service pack 3 windoze died - so I finally got my wife 
> > to work on my debian machine. Now I need to install debian on her amd64 
> > compaq, and unlike 15 month ago this time I cannot give up. The SATA 
> > drives are simply not recognized during installation. Threw in an old 8.6G 
> > ide hard drive that I had salvaged, and installed the system. Below is my 
> > dmesg output: the trail of the errors is clear, but even after a lot of 
> > googling I still have no idea as to what the root cause might be. Could 
> > not make sense of anything I found on the web. The chip is an ATI IXP 400.   
> > The BIOS does not seem to allow me to mess with any drive settings...
> > 
> >   :-(
> > 
> > Thanks for your help! 
> > 
> > Best, Kai 
> > 
> > P.S. Due to the high traffic I am not on the list. Please cc me in your 
> >      reply. - Will deal with the 8139too issue after I got the disk... 
> > 
> [snip]
> > ata1: EH complete
> > ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
> > ata1.00: cmd c8/00:08:00:00:00/00:00:00:00:00/e0 tag 0 dma 4096 in
> >          res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
> > ata1.00: status: { DRDY }
> > ata1: soft resetting link
> > ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
> > ata1.00: configured for UDMA/100
> > ata1: EH complete
> [snip]
> This is the best I could find from Google:
> http://bbs.archlinux.org/viewtopic.php?pid=275504
> - --
> Ron Johnson, Jr.
> Jefferson LA  USA
> "Kittens give Morbo gas.  In lighter news, the city of New New
> York is doomed."
> Version: GnuPG v1.4.9 (GNU/Linux)
> iEYEARECAAYFAkh8vtgACgkQS9HxQb37XmcxSQCePvRN0tpbkBuoP6f18rg4GaQ4
> 2bUAoOcwVwYTTZeupiG1vEIbQh7X6swI
> =oh6p


   Kai Martens				University of Utah
   Research Associate Professor		Department of Physics

   Tel:    (801) 585-5503		115 South 1400 East
   Fax:    (801) 581-6256		James Fletcher Bldg. Room 201
   E-mail: kai@physics.utah.edu		Salt Lake City
   Office: INSCC 216			Utah 84112-0830, USA


Reply to: