[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Sound Problems (Sound is Often Gone)

I'm using Kubuntu, but not the latest version, the one before it (Gutsy, 
I think) and KDE 3.5.8 and have been using OSS.

Many times I start a program and I don't get sound output.  Most of the 
time I'm using either Amarok, Flash (from Firefox or Konqueror), 
Kaffeine, and sometimes KMail (some message filters trigger sounds for 
me).  I'm not using any big games that take up the full screen, but I 
have a few like PySol or one or two that work under Wine.

I may start one program, like Amarok, and play music in it, then stop 
that music and run a game or try to watch something in Flash and may 
not get sound -- or if I've been playing a game, then try to run 
Amarok, I may have had sound for the game and not Amarok.

It used to be that I could have Amarok playing music in the background 
and play a game and I'd get the sounds from both, but not anymore.  At 
most one program can play sounds at a time (as best I can tell, I 
haven't tried every combination of programs).

Usually if I pull up the KDE control center and change from OSS Sound to 
Autodetect, hit "Apply" to restart, then switch BACK to OSS, and 
hit "Apply" again, I can get sound.  Even with this, though, there's a 
trick to it.  If I've played a game and had sounds with it, then I 
quite the program and start a song in Amarok (which was in the 
background all the time, just not playing) I won't get sound.  I have 
to quite Amarok, then do the KDE Control Center thing, THEN restart 
Amarok and it'll play.

I don't know the sound system well, but it seems to me that there's a 
problem with channels or resources not being freed up after they should 
be released or some multiplexing that is not happening.

I'm using a Soundblaster and nothing exotic.  This worked fine until I 
upgraded from Feisty Fawn to Gusty Gibbon.  I just haven't had time to 
worry about it until now, when I was playing a song in Amarok, hit 
the "Next Song" button and got a message "Audio Output Unavailable"  
I'm not sure about the rest of the message because I can't make it come 
up every time and it goes away quickly enough I haven't copied the 
whole thing, but it's something like "Device unavailable."  This has 
made it frustrating enough I just need to get it fixed.

I know that puts it onto something Kubuntu did wrong, but overall, I'd 
think that I should be able to use apt-get or dpkg-reconfigure to 
either remove and reinstall the sound system or to reconfigure it, but 
I'm not sure of all the packages that might be involved or if there's 
an easier solution.

Ideas, anyone?



Reply to: