[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: prob. w. wordpress + php5

Freddy Freeloader wrote:
Hugo Vanwoerkom wrote:

Sid has dropped apache in favor of apache2.

Apache2 does not have php4 support, only php5.

But WordPress, in particular the Textile 2cb plugin, has a bug in it using php5 that makes enumerated lists come out wrong.

I have the version of sid with apache + php4 on a mirror.

I want to install my system from scratch using the most recent sid but stay with apache + php4 from my mirror.

How would I do that?

It's either that or change the plugin because it is no longer supported by its author.


The wordpress package in Sid will work with php5. Here's the output from "apt-cache show wordpress":

Package: wordpress
Priority: optional
Section: web
Installed-Size: 5032
Maintainer: Andrea De Iacovo <andrea.de.iacovo@gmail.com>
Architecture: all
Version: 2.5.1-4
Depends: apache2 | httpd, virtual-mysql-client, libapache2-mod-php5 | php5 | php5-cgi | libapache2-mod-php4 | php4 | php4-cgi, php5-mysql | php4-mysql, libphp-phpmailer (>= 1.73-4), php5-gd | php4-gd, libjs-prototype, libjs-scriptaculous, tinymce (>= 3.0.7)
Suggests: virtual-mysql-server
Conflicts: mysql-server (<< 4.0.20-8)
Filename: pool/main/w/wordpress/wordpress_2.5.1-4_all.deb
Size: 1038376
MD5sum: 145d5509ea4b4067dded3ebd7736ffe9
SHA1: 08ce30c3d5e015ef7af2b5b2e02adee93659e322
SHA256: 43e390691e0725f1aacd6f3af6fe057d02c7d6afd776cb35f0253bcec8754ea7
Description: weblog manager
WordPress is a full featured web blogging tool:
   * Instant publishing (no rebuilding)
   * Comment pingback support with spam protection
   * Non-crufty URLs
   * Themable
   * Plugin support
This package includes French language support.
Homepage: http://wordpress.org
Tag: implemented-in::php, interface::web, web::blog

Looks to me like wordpress will run on php4 or php5.

Never mind. Brain fart on my part.

Reply to: