[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: alsaconf says "No supported PnP or PCI card found"

Wow! Five helpful people answered to my problem! Before I posted this, I had been searching the Internet and docs during many hours, and I felt alone and frustrated... Thank you Nigel, Chris, Thierry, Pol and Florian.

My problem needed indeed "just" a kernel upgrade, here is the summary of what I did:

# nano /etc/apt/sources.list
  (then added the following line:)
    deb http://www.backports.org/debian etch-backports main \
       contrib  non-free
# aptitude install debian-backports-keyring
# aptitude upgrade
# aptitude install linux-image-2.6.25-2.486
# reboot


On 7.07.2008 13:19, Luc Saffre wrote:

I just bought a desktop PC with a GeForce6100SM-M mainboard whose
NVIDIA MCP61S chipset is "High Definition Audio Specification 1.0
compliant". I installed the latest stable Debian (2.6.18-6-486),
everything worked well so far... except that there is no sound.

alsaconf says "No supported PnP or PCI card found"

I added a line "alias snd-card-0 snd-hda-intel" to
/etc/modutils/alsa-base and ran update-modules (after reading
http://www.alsa-project.org/main/index.php/Matrix:Module-hda-intel), but without result.

Here are some things I tried:

  # /etc/init.d/alsa reload
  Unloading ALSA sound driver modules: (none loaded).
  Loading ALSA sound driver modules: (none to reload).

  # lspci | grep Audio
  00:05.0 Audio device: nVidia Corporation MCP61 High \
     Definition Audio (rev 2a)

  # lsmod|grep snd
  # (no output)

There is no directory /proc/asound

I checked whether the normal user is in the audio group:
  # groups milvi
  # milvi : milvi dialout cdrom floppy audio video plugdev \
    netdev powerdev

I'd be glad if somebody can help me! I'm willing to learn and not really new to Debian, but audio configuration seems complex.


Reply to: