[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Advice for troubleshooting X (total screen loss) -- Newb Alert

Kent West wrote:
I would start by changing the nvidia driver to the nv driver in /etc/X11/xorg.conf

Mumia W. wrote:
Re-do dpkg-reconfigure xserver-xorg and select the "vesa" driver--just to check if the nvidia driver is the source of the problem.

Thanks for the suggestions.

I have retried using both of the generic drivers.  Now I'm getting a fatal server error -- no screens found.
Still not working, but at least it's enough to start me on further research.

I attempted lowering the resolution to see if that would let it detect the monitor (and also tried disabling glx) but neither resolved the problem; moreover, when I set x to autodetect the monitor, the screen goes black again with no signal to monitor and I'm forced to do a hard reboot by hitting the box's reset button.

The monitor in question is an Acer 22" lcd, if anyone out there has any experience with these.

I will keep looking into this and report back when I find a solution, but in the mean time if anyone has any further suggestions I am all ears :)


On Fri, Jun 27, 2008 at 1:53 PM, Mumia W.. <paduille.4061.mumia.w+nospam@earthlink.net> wrote:
On 06/27/2008 12:20 PM, Jeff Soules wrote:
Hi all,

Thanks for taking the time to read this.  I try to solve things by myself,
I'm at a loss for the next step in troubleshooting this one.

After install, I attempt to start X using startx.  A few lines of text flash
on the screen, then it blacks out and the system buzzer gives me one
short beep.  I cannot alt-Fx to any other terminal and lose the terminal
I'm working in, and have to restart with ctrl-alt-del.
I've tried to capture the text printed to screen before it blacks out
$ startx 2>&1 >xfail
but on the next restart, file xfail is empty.

I have a fresh install of Etch (AMD64 version) running on an Athlon64x2
dual-core proc.  Graphics card is an EVGA-branded nVidia 8600GT.
Display is a 22" Acer LCD; I ensured the refresh rates in the
x configuration were within monitor specs.

For setup, I installed the base system and a couple extra packages
(bastille, sudo).  Went through interactive bastille, set up my
sudoers file, then sudid:

apt-get install xserver-xorg-core
apt-get install x-window-system
apt-get install xserver-xfree86
apt-get install xserver-xorg
apt-get install x-window-system-core
apt-get install gnome-core
apt-get install enlightenment

then installed nvidia drivers:

apt-get install module-assistant gcc nvidia-kernel-common
apt-get install nvidia-kernel-2.6.18-6-amd64
apt-get install nvidia-glx

Then reconfigured the x server to use the nvidia driver using
dpkg-reconfigure xserver-xorg

Forced the nvidia driver to load at boot:
echo nvidia >> /etc/modules

(first time) manually loaded the nvidia module:
modprobe nvidia

...and then I try startx and get the uninformative results above.

If anyone can recommend next steps for troubleshooting or where
I should look for more information, I would be very grateful.


Jeff Soules

Re-do dpkg-reconfigure xserver-xorg and select the "vesa" driver--just to check if the nvidia driver is the source of the problem.

Also, I would reconsider bastille. I remember others saying that it was too buggy and not worth the problems it creates, but those comments might have been for Sarge.

To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: