[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: migrating Debian GNU/Linux Etch to second SATA drive



I am not sure if I understood you correctly, so please correct me if I am
wrong, but I assume:

* you have basically moved all needed partitions for a full Debian system from
  one disk to another,

* and now you want to install GRUB to this second disk so that GRUB can boot from that disk (and you can eventually remove the old disk from the system).

Can you still (temporarily) boot from your first disk where GRUB is still installed? You don't need to be able to boot Debian from the old disk, you just need a working GRUB install there. Does GRUB display a menu when you boot
from your old disk?

Then you can use the GRUB shell, and within the GRUB shell you can run several
commands to install GRUB to the second, new hard disk.

You get to the GRUB shell by pressing the "c" key when GRUB displays the menu. (Maybe you have to press "Esc" first, I am not sure and can't try it now.)

Let me know if this would work for you, then I could tell you more about which
commands to run in the GRUB shell.

Am 2008-05-08 um 23:12 schrieb Paul Csanyi:

Hello!

I tried to migrating from the first to second SATA drive My Debian
Etch OS with Gparted.

I copied the /, /usr, /var, swap, /tmp, /home partitions of the system
to the second SATA: sdb with Gparted.

Then I tried to set up grub to boot this Debian system from the first
SATA drive sda, and did the following:

- boot the install CD of the Etch Netinstall
- at prompt use expert
- ...
- detecting disks
- did not disk partition
- run a shell

Here I follow the mini howto:
http://wiki.archlinux.org/index.php/Reinstalling_GRUB

cd /
mount -t ext3 /dev/discs/disc1/part1 /mnt
# this is the / partition of the sdb
mount -t ext3 /dev/discs/disc1/part2 /mnt/usr
# this is the /usr partition of the sdb
mount -t proc proc /mnt/proc
mount -t sysfs sys /mnt/sys
mount -o bind /dev /mnt/dev
chroot /mnt /bin/bash

grub-install /dev/sda

Error: /dev/scsi/host1/bus0/target0/lun0/disc does not have any
corresponding BIOS drive.

I can't here as root to use nano because of the bterm error. I did the
following to get some editor, namely mcedit:

TERM=xterm
export TERM
mcedit /etc/fstab

I can to use here mcedit, but with difficulties. Still can to edit
fstab, however.

But, I can't to install grub to boot sdb root from the sda MBR.

Any advices will be appreciated!


--
Regards, Paul Csanyi
http://www.freewebs.com/csanyi-pal/index.htm


--
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org


Reply to: