[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing a Lenny package to an Etch machine

Paul Cartwright wrote:
On Mon March 31 2008, Andrei Popescu wrote:
First I would try to install it with 'dpkg -i'. Another option would be
to set 'APT::Default-Release "stable";' in /etc/apt/apt.conf, add a
source for lenny and try to install with
'aptitude install -t lenny homebank'. If this doesn't pull in too many
dependencies (where 'too many' depends on your luck/guts/phase of the
moon/...) than you're good to go.
I got it to install on my Etch system by doing this:
download 3 packages:
install in this order:

to download, get them here:


This sounded like a pretty straight forward response.

Once I downloaded the packages and went to install, this is what I got:

~$ sudo dpkg -i libofx4_0.9.0-2.1_i386.deb
(Reading database ... 178403 files and directories currently installed.)
Preparing to replace libofx4 1:0.9.0-2.1 (using
libofx4_0.9.0-2.1_i386.deb) ...
Unpacking replacement libofx4 ...
dpkg: dependency problems prevent configuration of libofx4:
 libofx4 depends on libc6 (>= 2.7-1); however:
  Version of libc6 on system is 2.3.6.ds1-13etch5.
 libofx4 depends on libstdc++6 (>= 4.2.1-4); however:
  Version of libstdc++6 on system is 4.1.1-21.
dpkg: error processing libofx4 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

Hmmm ... not so cool. So this is where I am stuck. Especially since apt-get install libstdc++6 seems to kick up an error about version numbers, wherein the present installed version is more recent than the recommended version number.


I have decided to go for kmymoney2 instead. :-)

At least that installed fine.


Andy (he who is dubious about traversing Dependency Hell)


"If they can get you asking the wrong questions, they don't have to worry about the answers." - Thomas Pynchon, "Gravity's Rainbow"

Reply to: