[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Recommended Packages acting like Required

On Sun, Mar 30, 2008 at 05:05:11PM +0000, Greg Cox wrote:

> If you look at http://packages.debian.org/lenny/spamassassin, libmail-spf-perl is a recommended, not a required.

Since version 0.7.7 apt installs Recommends by default. I think you want 
something like this in apt.conf:

APT::Install-Recommends false;

> If I try to upgrade openssh-client openssh-server and ssh:
> The following extra packages will be installed:
>   cpp cpp-4.2 gcc-4.2-base libx11-6 libx11-data libxau6 libxdmcp6 libxext6 libxmuu1 x11-common xauth
> cpp isn't even listed in the web page.

openssh-server (and -client) recommends xauth which depends on cpp.

If you can't explain it simply, you don't understand it well enough.
(Albert Einstein)

Attachment: signature.asc
Description: Digital signature

Reply to: