[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: openssh 4.7p1 Debian-4, OpenSSL 0.9.8g hangs after authentication [SOLVED]

On 29/03/2008, Eike Lantzsch <zp6cge@gmx.net> wrote:
>  I suspected the firewall on the workstation and casually CTRL-ALT-F2'ed into a
>  console. I logged on as the same user. Lo-and-behold: It works fine on the
>  same machine in a text console. I went back to KDE and tried an xterm instead
>  of Konsole. It also hangs with xterm. That flabbergasted me completely. How
>  can OpenSSH be different when using it in a terminal window than on a console
>  while X is still running on ALT-F7?
>  So it IS different. I deleted /tmp/ssh-pscjC23970 which is not created when
>  starting ssh in a text console. Now ssh works again from an xterm and
>  Konsole.

/tmp/ssh-pscjC23970 is a socket file created by ssh-agent(1).  It
seems that KDE starts ssh-agent, while that doesn't happen when you
login.  Anyway, ssh look for a running ssh-agent by reading the
variable SSH_AUTH_SOCK; this is setup by KDE when it launches
ssh-agent, while in the console there is no such variable (or, if
there, refers to a different instance).  This explains the different
behavior, but why ssh hangs when connecting to ssh-agent I don't know.


Reply to: