[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: openssh 4.7p1 Debian-4, OpenSSL 0.9.8g hangs after authentication [SOLVED]

On Friday 28 March 2008, Joost Witteveen wrote:
> On 27/03/2008, Eike Lantzsch <zp6cge@gmx.net> wrote:
> > Hi:
> >
> >  Does somebody have a hint for me how to investigate this problem
> > further: Openssh hangs from my workstation to any ssh-server including
> > the workstation itself.
> >  Using another client machine I can ssh into all machines allright,
> > including the Fawlty [(c)John Cleese] one. One has also installed Debian
> > testing with the very same version of openssh and openssl.
> >
> >  myuser@myworkstation:~$ ssh -vv -4 -2 -l myuser
> [...]
> >  debug2: service_accept: ssh-userauth
> >  debug1: SSH2_MSG_SERVICE_ACCEPT received
> I'd run strace on it.
> When I do
>   strace -f ssh -vv -4 -2 -l joostje muso.komputilo.org 2>strace.txt

Thank you very much for your reply.

When I strace I get these lines after the ACCEPT statement

debug1: SSH2_M) = 42
socket(PF_FILE, SOCK_STREAM, 0)         = 10
fcntl64(10, F_SETFD, FD_CLOEXEC)        = 0
connect(10, {sa_family=AF_FILE, path="/tmp/ssh-pscjC23970/agent.
write(10, "\0\0\0\1", 4)                = 4
write(10, "\v", 1)                      = 1
read(10,.		[rest of the command missing]

So it seems to hang with a read().

I suspected the firewall on the workstation and casually CTRL-ALT-F2'ed into a 
console. I logged on as the same user. Lo-and-behold: It works fine on the 
same machine in a text console. I went back to KDE and tried an xterm instead 
of Konsole. It also hangs with xterm. That flabbergasted me completely. How 
can OpenSSH be different when using it in a terminal window than on a console 
while X is still running on ALT-F7?

So it IS different. I deleted /tmp/ssh-pscjC23970 which is not created when 
starting ssh in a text console. Now ssh works again from an xterm and 

So strace really DID help. Still I don't seem to grasp the workings of 

Thank you again. And thank you to Christian Koerner as well.
Sorry for the delay but I was sick and didn't have access to this computer.

Cheers, Eike

Reply to: