[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

qemu debian install raw, cannot compress and copy to another machine, works on original



Hi

I am playing with qemu. I created a debian vm.
I did not  use the qcow format, instead just  big and raw.

qemu-img debian.img 10G

then i installed debian as usual

qemu -boot d -cdrom /dev/cdrom -hda debian.img

Now it works fine. I made some ovl files and they work too

Now I tried to copy this debian.img to another machine. I did not want
to copy the whole big file so I did

tar -csjf debian.tar.bz2 debian.img

then i copied it to another machine.

i checked the md5sum and i ran 

bunzip2  debian.tar.bz2
and 
tar xvf debian.tar

Now if I copy this file to another directory
and run
bunzip2 debian.tar.bz2
tar xvf debian.tar

Then if I run 

qemu -hda debian.img -boot c

then it runs fine.

However if I move it to another debian machine

and if I check the md5sum (and they agree!) 



then when I try to run the debian machine on the new machine I  get an
error

ata0 master: QEMU HARDDISK ATA-7 Hard-Disk (  0 MBytes)

Booting from Hard Disk...
Boot from Hard Disk failed: not a bootable disk

FATAL: No bootable device


:(.

I have tried it on multiple different machines.

any ideas?


Mitchell





Reply to: