[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 8139cp 0000:03:08.0: This (id 10ec:8139 rev 10) is not an 8139C+ compatible chip

On Sat, Mar 01, 2008 at 10:00:49PM +0000, Jamin Davis wrote:
> stephane lepain wrote:
>>> For your problem you could try placing 8139too into
>>> /etc/modules
>>> That might see that your 8139too driver gets loaded first.
>>> Incidentally comment any references to 8139cp that you run across. HTH
>>> Adrian
>> After one day of trying to dig up a solution for my problem. I have  
>> given up
> You might need a little more patience using Linux ;-).

but once it's working, it'll work so well for so long that you'll
forget how to fix it if it comes up again...

>> Nothing seems to be working. I still get the same error message
>> "8139cp 0000:03:08.0: This (id 10ec:8139 rev 10) is not an 8139C+  
>> compatible chip"
> You can blacklist the 8139cp module in /etc/modprobe.d/blacklist file  
> (might need to create this if it doesn't already exist):
> blacklist 8139cp
> and if you have 8139too in /etc/modules then the boot process should  
> load that instead of 8139cp. I have checked on a machine which has an  
> 8139too NIC and that works for me. There's a package called nictools-pci  
> which has a file rtl8139-diag -- might be useful for fixing 8139 related  
> probs.

and the blacklisting won't work if the module is in your initrd! You
at least need to run update-initramfs and you would probably be
advised to unpack one to make *sure* it's not in there... 


Attachment: signature.asc
Description: Digital signature

Reply to: