[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: missing serial script in /etc?



Douglas A. Tutty wrote:
On Sun, Feb 24, 2008 at 02:31:52PM +0100, eric s wrote:
the serial port do not get created at start up?

there is no /etc/rc.serial script
or /etc/rc.local
or where is the serial port initiation script?

I'm on a 2.6.18 etch stable
anyone who has a script laying around?

To what script are you referring?  There is no startup script to create
serial devices.  They are there already in /dev

crw-rw---- 1 root dialout   4,   64 Feb 24 11:06 ttyS0
crw-rw---- 1 root dialout   4,   65 Feb 24 10:35 ttyS1
crw-rw---- 1 root dialout   4,   66 Feb 24 10:35 ttyS2
crw-rw---- 1 root dialout   4,   67 Feb 24 10:35 ttyS3

What problem are you having?

Doug.


well, the /dev/ttyS* didn't exists so I created /dev/ttyS* using ./MAKEDEV
and here is what I got:

# setserial -ag /dev/ttyS*
/dev/ttyS0, Line 0, UART: unknown, Port: 0x03f8, IRQ: 4
        Baud_base: 115200, close_delay: 50, divisor: 0
        closing_wait: 3000
        Flags: spd_normal skip_test

/dev/ttyS1, Line 1, UART: unknown, Port: 0x02f8, IRQ: 3
        Baud_base: 115200, close_delay: 50, divisor: 0
        closing_wait: 3000
        Flags: spd_normal skip_test

/dev/ttyS2, Line 2, UART: unknown, Port: 0x03e8, IRQ: 4
        Baud_base: 115200, close_delay: 50, divisor: 0
        closing_wait: 3000
        Flags: spd_normal skip_test

/dev/ttyS3, Line 3, UART: unknown, Port: 0x02e8, IRQ: 3
        Baud_base: 9600, close_delay: 50, divisor: 0
        closing_wait:

then I connected a bluetooth device and got the data in as serial line 9600, and can see the data fine in
cat /dev/rfcomm1

I created a symlink
ln -s /dev/rfcomm1 /dev/ttyS3
but all I got at cat /dev/ttyS3
is
cat: /dev/ttyS3: Input/output error


-eric


Reply to: