[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ksudoku fails to compile or start

On Fri February 1 2008, Sven Joachim wrote:
> If 13.4 MB of download is too much for you because you're on a slow
> dial-up, you may consider purchasing Debian DVDs.  The 50 MB and 68
> additional packages should not bother you, because aptitude will
> automatically deinstall them when you're done with the compilation and
> remove the kdelibs4-dev package.

it wasn't an issue of speed.. I was more worried about a bunch of extra 
packages that weren't there before, yet now I need them because of ksudoku?
so I added the kdelibs4-dev and ran the cmake again, success:
# cmake . -DCMAKE_INSTALL_PREFIX:PATH=`kde-config --prefix`
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found KDE3 include dir: /usr/include/kde
-- Found KDE3 library dir: /usr/lib
-- Found KDE3 dcopidl preprocessor: /usr/bin/dcopidl
-- Found KDE3 dcopidl2cpp preprocessor: /usr/bin/dcopidl2cpp
-- Found KDE3 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- intstall prefix: /usr
-- Configuring done
-- Generating done
-- Build files have been written to: /home/pbc/Documents/software/ksudoku-0.4

then I ran :
#  make install

from another terminal window:
$ ksudoku
bash: /usr/games/ksudoku: No such file or directory
$ /usr/bin/ksudoku
Segmentation fault

so the make install moved the executable to /usr/bin, yet the system still 
thinks it is in /usr/games, and it still doesn't work.

Paul Cartwright
Registered Linux user # 367800
Registered Ubuntu User #12459

Reply to: