[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ksudoku fails to compile or start

On Fri February 1 2008, Sven Joachim wrote:
> Did you install the build-dependencies for ksudoku, e.g. with
> "apt-get build-dep ksudoku"?  It looks as if kdelibs4-dev is missing.

apt-get didn't work, and aptitude install kdelibs4-dev required way too many 
other files to be installed.

# apt-get build-dep ksudoku
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Could not open 
file /var/lib/apt/lists/Debian%20GNU_Linux%204.0%20r0%20%5fEtch%5f%20-%20Official%20Multi-architecture%20i386_amd64_powerpc_source%20DVD%20%231%2020070407-12:57_dists_stable_contrib_source_Sources - 
open (2 No such file or directory)
# aptitude install kdelibs4-dev 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information      
Initializing package states... Done
Reading task descriptions... Done  
Building tag database... Done    
The following packages are BROKEN:
  gamin libgamin0 
The following packages have been kept back:
The following NEW packages will be installed:
  fam{a} hspell{a} kdelibs4-dev libacl1-dev{a} libart-2.0-dev{a} 
  libarts1-dev{a} libartsc0-dev{a} libasound2-dev{a} libaspell-dev{a} 
  libaudio-dev{a} libaudiofile-dev{a} libavahi-client-dev{a} 
  libavahi-common-dev{a} libavahi-qt3-dev{a} libbz2-dev{a} libdbus-1-dev{a} 
  libesd0-dev{a} libfam-dev{a} libfam0{a} libgl1-mesa-dev{a} 
  libglu1-mesa-dev{a} libidn11-dev{a} libjack-dev{a} libjack0.100.0-dev{a} 
  libjasper-dev{a} liblcms1-dev{a} liblua50-dev{a} liblualib50-dev{a} 
  libmad0-dev{a} libmng-dev{a} libogg-dev{a} libopenexr-dev{a} 
  libpcre3-dev{a} libqt3-compat-headers{a} libqt3-headers{a} 
  libqt3-mt-dev{a} libsasl2-dev{a} libtiff4-dev{a} libtiffxx0c2{a} 
  libvorbis-dev{a} libxml2-dev{a} libxmu-dev{a} libxmu-headers{a} 
  libxslt1-dev{a} libxt-dev{a} lua50{a} mesa-common-dev{a} qt3-dev-tools{a} 
0 packages upgraded, 48 newly installed, 0 to remove and 1 not upgraded.
Need to get 13.4MB of archives. After unpacking 50.1MB will be used.
The following packages have unmet dependencies:
  gamin: Conflicts: fam but 2.7.0-13 is to be installed.
  libgamin0: Conflicts: libfam0c102 but it is not installable
             Conflicts: libfam0 but 2.7.0-13 is to be installed.
Resolving dependencies...
The following actions will resolve these dependencies:

Install the following packages:
libgamin-dev [0.1.9-2 (testing)]

Keep the following packages at their current version:
fam [Not Installed]
libfam-dev [Not Installed]
libfam0 [Not Installed]

Score is 68

Accept this solution? [Y/n/q/?]         ah, NO.

Paul Cartwright
Registered Linux user # 367800
Registered Ubuntu User #12459

Reply to: