[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Terminal issues in fresh install

Greetings, all!

I've just moved over from an ancient self-hosted Debian box onto some
more modern hardware and things are going mostly smoothly, but I'm
having some issues with mutt's thread indicators (extended-ASCII arrows)
displaying improperly.  I've double-checked that I've got all locale
settings set to en_US.UTF-8 (with the sole exception of LC_COLLATE,
which I prefer to keep at C) and done a dkpg-reconfigure locales to
verify that en_US.UTF-8 is generated (it is; actually, it's the only
thing that is).  mutt is at the latest version from stable and, noticing
that there's a mutt-utf8 mentioned as conflicting with it, I tried
installing that, but it appears to be an obsolete UTF-8 support package
which no longer exists.

Is it significant that the old machine was using the basic en_US locale
or that I've been accessing both of them via ssh from a workstation with
its locale set to C?  I also am using a customized terminfo (to prevent
the screen from resetting when I exit less/vi/etc.), but tried disabling
that and relogging, which had no effect, so I don't think it's likely to
be the cause.

As a side question, this new install was done by the hosting provider,
who is primarily familiar with Red Hat, so everything was configured to
the defaults.  Package configurations are also displaying the same
symptoms as mutt, since they're using the (default) curses interface.
Which I've never liked anyway.  How do I switch it over to the plain-text
(readline?) interface?  I've tried dpkg-reconfigure dpkg and apt, since
they seemed the likely suspects, but neither one offered any options to

I reckon we are now the only monastry ever that had a dungeon stuffed with
sixteen thousand zombies.
  - perlmonks.org

Reply to: