[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X server on lenny - broken after today's dist-upgrade

Hash: SHA1

On 11/18/07 04:08, David Fox wrote:
> I am having a problem and I've only got a minimal xfce4 setup right
> now, enough to press alt-f2 to run iceweasel. I've basically lost the
> ability to start x into my normal KDE environment. I get some errors
> on the controlling terminal - these error messages are strange to me.
> startkde never gets to start; I get a blue screen with a mouse cursor,
> and nothing more.
> In desperation, I tried geting X back by doing a basic reinstall of
> the xserver-xorg package but in turn seemingly lost nvidia - and now I
> cannot install nvidia-glx. I had it running (from sid) up until now.
> Most if not everything xserver-xorg is running from sid rather than
> from lenny because at the time lenny did not have nvidia-kernel-source
> or the proper revision of nvidia-glx.
> When I attempt to install nvidia-glx I get unresolved dependencies
> wanting nvidia-kernel-100.14.19, saying this is a virtual package. But
> I want nvidia-kernel-source and nvidia-kernel-common, right?
> I have those two packages installed from sid's repository but still
> can't get nvidia-glx (re)installed.
> Also this setup as it is is difficult to get a cut/paste or a script
> of the error(s) I get when I try and startx with my normal kde
> install. But I remember errors along the line of bad font path element
> - and unfortunately, nothing in /var/log/Xfree86 seems to be there
> detailing these errors.
> I'll probably follow up to this message in a little bit.
> Meanwhile, X is at least *somewhat* usable but this partial xfce
> environment I have (no taskbars, no panel, nothing but a gray screen
> and alt-f2 to run an app) isn't wanting to be tried that much longer.

This might not help you much, but I just upgraded Sid this afternoon
and (using startx) GNOME and my self-installed nvidia 100.14.19
driver work fine.

- --
Ron Johnson, Jr.
Jefferson LA  USA

%SYSTEM-F-FISH, my hovercraft is full of eels
Version: GnuPG v1.4.6 (GNU/Linux)


Reply to: