[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: No sound with video--Solved

On Fri, 2007-11-16 at 10:53 +0100, Florian Kulzer wrote:
> On Thu, Nov 15, 2007 at 16:32:46 -0500, Tom Ashley wrote:

> > Hi John,
> > 
> > Thanks for the response.  I can play the mp3s withouth any problem.  My
> > problem appears to be limited to flash audio.
> The default configuration for iceweasel is ICEWEASEL_DSP="none" which
> means it will try to play audio by accessing the ALSA /dev/snd/* devices
> directly. (You can change this setting in /etc/iceweasel/iceweaselrc, as
> Andrei has already pointed out.)

> If I run iceweasel in this default configuration and play a youtube
> video (with sound, of course) then I see this:
> $ lsof -w | egrep 'snd|dsp'
> npviewer. 9886  florian  mem  CHR 116,16  7092 /dev/snd/pcmC0D0p
> npviewer. 9886  florian  63r  CHR 116,33  7000 /dev/snd/timer
> npviewer. 9886  florian  64u  CHR 116,16  7092 /dev/snd/pcmC0D0p
> (I edited the output above to trim excessive whitespace.)
> This means that iceweasel's flash plugin cannot play sound if some other
> process is blocking these devices. If you are using KDE or Gnome then
> the devices are probably under the control of a sound daemon (artsd or
> esd, respectively). Run the "lsof -w | egrep 'snd|dsp'" command before
> you start iceweasel to see which process is blocking the device(s). The
> first quick test is to kill the blocking process and check if this
> allows iceweasel to play sound in flash movies.
> If a sound daemon is indeed responsible for locking the devices then you
> can either tell it to share the device (this is possible in KDE, I don't
> know about Gnome's esd) or you can try to configure iceweasel for
> playing audio via the sound daemon by putting one of these into
> /etc/iceweasel/iceweaselrc:
> ICEWEASEL_DSP="artsdsp"  # for KDE's artsd
> or
> ICEWEASEL_DSP="esddsp"  # for Gnome's esd
> Iceweasel has to be restarted after changing the settings. I took these
> options from "man iceweasel" but I never tried them myself. (I told my
> artsd not to hog the ALSA devices and this works fine with iceweasel's
> default DSP="none" setting.)
> -- 
> Regards,            | http://users.icfo.es/Florian.Kulzer
>           Florian   |
Hi Florian,

Using the clues from your reference to /dev/snd, I discovered I had
no /dev/snd/ and esd was not being loaded.  Unable to determine why by
Googling, I decided to remove all ALSA and ESD related packages and to
reinstall.  In doing so, /dev/snd/ was created and ESD is now active.

Thanks to all for your patience and help.


Reply to: