[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Deletion of files from usb-key



Kiran,

Thanks for the help. I should emphazie that my promblem is not
mounting the usb-key drive, but only deleting the files on it. I can
copy those files, but not delete or modify them. However, if I add a
test file, I can readily delete it.

I suspect I damanged the file system by removing the usb-key from a
laptop running Windows without first "stopping" it  (I know nothing of
Windows). 

You suggested first:

	# dd if=/dev/zero of=/sdd bs=512 count=1	
	1+0 records in
	1+0 records out
	512 bytes (512 B) copied, 0.00394563 seconds, 130 kB/s

This didn't get rid of the files.

You suggested second:

	# mkdosfs -I -v /dev/sdd
	mkdosfs 2.11 (12 Mar 2005)
	/dev/sdd has 16 heads and 62 sectors per track,
	logical sector size is 512,
	using 0xf8 media descriptor, with 1000944 sectors;
	file system has 2 16-bit FATs and 16 sectors per cluster.
	FAT size is 245 sectors, and provides 62526 clusters.
	Root directory contains 512 slots.
	Volume ID is 47326c96, no volume label.

Files still there. 

Important relevant information:

	$ ls -la /media/usb-key
	drwxr-xr-x 2 brownh brownh    20480 Dec 31  1969 .
	drwxr-xr-x 8 root   root       4096 Jul 17 15:16 ..
	-rwxr-xr-x 1 brownh brownh  1071529 Aug 14 14:35 <.PNG filename>
	...

	$ df /media/mirror
	Filesystem     1K-blocks     Used Available Use% Mounted on
	/dev/sda1         964500   124352    791152  14% /

I next tried to repair the file system;

	# dosfsck -av /dev/sdd
	dosfsck 2.11 (12 Mar 2005)
	dosfsck 2.11, 12 Mar 2005, FAT32, LFN
	Logical sector size is zero.

Zero? 

I said that running mformat failed. What I meant is that I only get
the usage help, but nothing happens: 

	# mformat -v /dev/sdd
	Mtools version 3.9.10, dated March 2nd, 2005
	Usage: ...

I tried:

	# fdisk /dev/sdd

and print partition table:

	Disk /dev/sdd: 512 MB, 512483328 bytes
	16 heads, 62 sectors/track, 1009 cylinders
	Units = cylinders of 992 * 512 = 507904 bytes

	   Device Boot      Start         End      Blocks   Id  System
	/dev/sdd1               1        1009      500433    b  W95 FAT32

This looks OK.

-- 
 
       Haines Brown, KB1GRM

	 
        



Reply to: