[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Telnet/SSH Terminal Help

Nate Duehr wrote:

On Oct 28, 2007, at 10:37 PM, Jeff Grossman wrote:

I do all of my administration on my Debian system using either Telnet or SSH from a remote computer. But, when I run programs like aptitude or mc it does not show any lines just funky characters for the lines. I did a screen shot and put it up on my webpage if anybody would like to take a look and tell me what I have configured wrong.


That looks similar to some things I saw when SSH'ing from a Mac OSX machine to a Debian system and running Aptitude.

Switching the Mac's Terminal application over to using "xterm-color" for the terminal type, straightened it right up.

Even if you're not on a Mac, it's a problem with the terminal emulation of the machine you're on, and what the terminal emulation is set up as on the Debian machine in $TERM in the shell.

You can probably find a combination that works properly though, if you hunt a bit. Don't forget to "reset" in the shell each time you change your terminal emulation on your machine you're testing from, if you're not disconnecting and reconnecting.

What I am confused about is I am running the exact same terminal in both Debian and the client as I did in Gentoo and I had the lines drawn in mc. I am using the linux terminal. When I run 'echo $TERM' it says linux and my client says linux which I have not changed from when I connected to Gentoo.

I just connected to a Gentoo box to make sure I am correct, and yes, I echo the term and it says linux and the lines are drawn in mc. I just don't know where my configuration is different.


Reply to: