[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: package system broken by aptitude removing cupsys

On 09/04/2007 12:10 PM, Steve Newcomb wrote:
I am a long-time Debian user and sysadmin and I'm very frustrated
these days.  There seems no way out of my problem, other than to
re-install the entire OS from scratch and then simply *not* attempt to
replace cupsys, which still doesn't work.  I have fallen into this
"now start all over" trap several times over the past year or so.  It
is really bad, and advice would be welcome.

Once again, I've just installed a new OS (this time, lenny, but the
same problem has occurred repeatedly with etch) using the Sep 2 2007
daily build of netinst.

I don't know how to prevent cupsys from being installed,

You can prevent cupsys from being installed by creating a file called /etc/apt/preferences. Read "man apt_preferences". Your preferences file might contain this:

Package: cupsys
Pin: version *
Pin-Priority: -1

so, once
again, I've hoped that cupsys and all its gnome-trickery would work
properly.  Unfortunately, it still doesn't, at least insofar as my
microsopic remaining patience with it allows me to determine.

What do you mean by gnome-trickery?

Once again, I've tried to use aptitude to remove cupsys and replace it
with lprng.

Cupsys once again fails to remove itself, failing on the removal of
python-qt3 and/or python-sip4.

I can't see how cupsys is dependent upon python-qt3 or python-sip4 in Etch. I don't have Lenny.

Worse, once this failure occurs,
aptitude doesn't work any more. Thereafter, all
installations/de-installations fail with messages that include:

warning: Python C API version mismatch for module time: This Python has API version 1012, module time has version 1013.
warning: Python C API version mismatch for module _locale: This Python has API version 1012, module _locale has version 1013.
warning: Python C API version mismatch for module select: This Python has API version 1012, module select has version 1013.
Traceback (most recent call last):
  File "/usr/bin/pycentral", line 1394, in ?
  File "/usr/bin/pycentral", line 1388, in main
    rv = action.run(global_options)
  File "/usr/bin/pycentral", line 879, in run
  File "/usr/bin/pycentral", line 544, in read_version_info
    self.version_info = pyversions.parse_versions(self.version_field)
  File "/usr/share/pycentral-data/pyversions.py", line 29, in parse_versions
    import operator
ImportError: /usr/lib/python2.5/lib-dynload/operator.so: undefined symbol: PyInt_FromSsize_t

For months, now, the API mismatch has been the same two version
numbers: 1013 and 1012.

Many weeks ago, thinking that it was a problem with Python 2.5, I
wrote to the maintainer of that package.  No answer.  Anyway, I'm
not sure that it's his problem.

All advice welcome.

I'm CC'ing you because I don't know that you're subscribed.

Try to use "dpkg -r" to remove all of the offending packages.

How did you get cupsys installed in the first place? It doesn't seem to be required by either the kde or gnome packages, and you don't sound like a big fan of cupsys, so I assume that you didn't install it on purpose.

It would probably be useful to post your /etc/apt/sources.list and the output of 'dpkg --get-selections'

You might be mixing distributions or installing non-Debian packages (e.g. Ubuntu) that mess up your system.

Reply to: