[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Ndiswrapper and essids

[I'm cc'ng Kel Modderman, the Debian maintainer of ndiswrapper and a
member of the Debian Madwifi team, who has been helpful to me in the
past with wireless issues]

I recently had quite a frustrating time debugging a sudden ndiswsrapper
failure.  No errors, but the card (a Broadcom 4318 Air Force One)
stubbornly refused to work. Earlier the same day, it had worked fine on
my home network, and now it wouldn't work on a public hot spot,
although the last time I had tried the hot spot, several weeks earlier,
it had worked fine.

By carefully following the ndiswrapper troubleshooting guide [0], I
eventually solved the problem; the card now required the essid to be
manually set before it would associate.  The odd thing is that this did
not used to be the case; I hadn't experienced the problem before
because the card used to have the MS Windows-ish behavior of
associating with an open AP automatically.  I see this even now with
kernel 2.6.21 / ndiswrapper 1.43, while kernel 2.6.22 / ndiswrapper
1.47 seems to require a manual setting of the essid, as above.

Is this a bug, a feature or a quirk of my setup? I note that my Atheros
PCMCIA card (driven by madwifi) still associates automatically, while
the Broadcom one doesn't with the 2.6.22 / 1.47 combination, and I
also notice that the Broadcom doesn't even with 2.6.21 when using
the bcm43xx native driver.


mailmin.sourceforge.net - remote access via secure (OpenPGP) email
ssuds.sourceforge.net - A Simple Sudoku Solver and Generator

Reply to: