[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

way of getting flashplayer9 to work in amd64 etch....

Dear Debianists

I have just got flashplayer9  working on Iceweasel in amd64 etch.....

I did the following stuff recommended by some helpful guys at http://www.dipconsultants.com:

First things first, as root:

  * Add repository to sources.list:
o echo "deb http://www.dipconsultants.com/debian etch main" >> /etc/apt/sources.list
  * apt-get update
* Install the keyring so you're not bothered with key/verification warnings:
        o apt-get install markybob-keyring
  * apt-get update once more
  * Install what you want:
        o apt-get install ia32-libs-gtk nspluginwrapper

If you're looking to install Flash in a 64-bit browser:

  * Do *every* step listed above, then the following as a *user*, not root:
* wget http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_9_linux.tar.gz
  * tar -zxf install_flash_player_9_linux.tar.gz

It worked fine up to here....

* mv install_flash_player_9_linux/flashplayer.xpt install_flash_player_9_linux/libflashplayer.so ~/.mozilla/plugins/

Instead of this I did mv install_flash_player_9_linux/flashplayer.xpt install_flash_player_9_linux/libflashplayer.so /usr/lib/mozilla/plugins/
NOT as a user as root

  * nspluginwrapper -i ~/.mozilla/plugins/libflashplayer.so

I didn't do the above one either;

I did nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so
NOT as a user as root

  * Start/restart iceweasel/firefox/whatever
  * Enjoy, Etch 64-bit users, from the guys at dipconsultants.com :)

Everything else was the same.

Now flashplayer 9 works on my 64 bit Iceweasel browser.


Michael Fothergill

I tried flashplayer-mozilla or whatever it is. It doesn't work as far as I can see unless you are running Sid or Lenny or something because you can't install the latest nspluginwrapper in etch without dependency problems that I think would be dodgy because you would be veering out of etch into something chaotic.

Or something like that.

But this worked.

The next generation of Hotmail is here!  http://www.newhotmail.co.uk

Reply to: