[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Building fglrx on Lenny

On Wed July 11 2007 04:32, koffiejunkie wrote:
> I just noticed that kernel 2.6.21 is available in Lenny.  Finally - my
> CPU fan will work correctly!
> So I have one problem,  building the fglrx module fails with this message:
>   Building modules, stage 2.
>   MODPOST 1 modules
> FATAL: modpost: GPL-incompatible module fglrx.ko uses GPL-only symbol
> 'paravirt_ops'
> make[2]: *** [__modpost] Error 1
> make[1]: *** [modules] Error 2
> make[1]: Leaving directory `/usr/src/linux-headers-2.6.21-2-k7'
> make: *** [kmod_build] Error 2
> Is there a way around this?   Strangely, it doesn't happen on 2.6.18

I just installed the ati drivers from the ati website yesterday with that 
kernel and it succeeded. Are you building the fglrx package in debian? I had 
that problem with the nvidia drivers also. I read at kernel.org that 
paravirt_ops is no longer a GPL-only export in the current kernel 2.6.22. I 
don't know of a workaround.

Reply to: