[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

lost sound after dist-upgrade

I recently lost sound after a dist-upgrade to Debian 4.0.  Not sure why, though
I do have a new kernel, 2.6.18-4-486, replacing 2.6.8-2-386.

Now xmms gives an error message, "couldn't open audio."

When I originall installed Debian stable on this computer a year or so ago,
sound worked fine with no interference from me.

Here is some information I have found:
$ ls /proc/asound/cards
0 [SI7012         ]: ICH - SiS SI7012
                      SiS SI7012 with ALC655 at 0xe000, irq 217

$ lsmod (sound related stuff)
i810_audio             31380  0 
ac97_codec             17292  1 i810_audio
snd_intel8x0           29852  1 
snd_ac97_codec         82848  1 snd_intel8x0
snd_ac97_bus            2432  1 snd_ac97_codec
snd_pcm                65928  2 snd_intel8x0,snd_ac97_codec
snd_timer              19972  1 snd_pcm
snd                    45412  6 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
soundcore               8928  2 i810_audio,snd
snd_page_alloc          9736  2 snd_intel8x0,snd_pcm

$ dmsg
ACPI: PCI Interrupt 0000:00:02.7[C] -> GSI 18 (level, low) -> IRQ 217
intel8x0_measure_ac97_clock: measured 54656 usecs
intel8x0: clocking to 48000
agpgart: Detected SiS 741 chipset
agpgart: AGP aperture is 128M @ 0xd0000000
Intel 810 + AC97 Audio, version 1.01, 22:46:57 May  9 2007

I thought that maybe sound was muted so I tried:
$ setmixer -V vol 70,70
Error opening /dev/mixer

Unfortunately /dev/mixer does not exist.  Neither does /dev/dsp.

I just downloaded the alsa mixer gui.  When it starts the master volume appears
to be muted, but when I adjust the sound I still get the same message from xmms.

I notice that I don't seem to have any alsa packages installed.  None were
removed during the upgrade.

Any suggestions would be greatly appreciated.

Reply to: