[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Etch: network won't work

> what happens if you do a ifconfig eth0 up ?

I get the "No such device" error

> what are the contents of /etc/network/interfaces?

$ cat /etc/network/interfaces
auto lo eth0
iface lo inet loopback
iface eth0 inet static

> whats the output of lspci?

$ lspci
00:00.0 Host bridge: Intel Corporation 440LX/EX - 82443LX/EX Host bridge 
(rev 03)
00:01.0 PCI bridge: Intel Corporation 440LX/EX - 82443LX/EX AGP bridge (rev 
00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:0e.0 Ethernet controller: Realtek Semiconductor Co., Ltd. 
RTL-8139/8139C/8139C+ (rev 10)
01:00.0 VGA compatible controller: Intel Corporation 82740 (i740) AGP 
Graphics Accelerator (rev 21)

> you might also want to try to add 8139cp to /etc/modprobe.d/blacklist and 
> adding some of these boot options to /boot/grub/menu.lst:
> irqpoll
> pci=biosirq
> pci=irqmasq

I tried all of these together - still no luck.  It still loads 8139cp 
despite it being in the blacklist file.  I have tried removing and reloading 
8139too and 8139cp, then restarting the network - still no luck.

Will try new kernel from backports next. 

Reply to: