[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Complete KDE crash (since last upadate)

----- Nachricht von florian.kulzer+debian@icfo.es ---------

On Thu, May 24, 2007 at 08:37:02 +0200, kristian DOT mailinglists AT ewetel DOT net wrote:
----- Nachricht von Florian Kulzer ---------
     Datum: Wed, 23 May 2007 22:01:00 +0200
   Betreff: Re: Complete KDE crash (since last upadate)
        An: debian-user AT lists DOT debian DOT org

On Wed, May 23, 2007 at 20:12:49 +0200, kristian DOT mailinglists AT
ewetel DOT net wrote:

I have a big problem sincen the update on Monday evening, 21.5.
I use an aspire laptop with sid and kernel 2.6.20.

When I tried to login at kdm after the update, after giving the user and
pass, the kde welcome-screen comes up. The start window with the symbols
showing what  loads at the moment stopped at the second one (I think
"devices") for 30 seconds. After that I got my backround image (without
desktop icons) and a grey bottom-bar (where normally the kde-taskbar is)
and a moveable mouse cursor. Nothing more! No interaction possible. I
installed fvwm to use my programs.

I tried it several times, sometimes it hangs completely at the second
symbol, blinking but nothing more.

Is the reason a broken KDE, I have no explanation.

The /var/log/kdm.log gave no help.


We have the same problem now,

I tested KDE with a new user but it was the same. Then I listed my 3.5.7
packages, I got a long list with allmost all kde packages I have. The only
3.5.6 packages are:

kde-i18n-de 4:3.5.6-1
ksync 4:3.5.6.dfsg.1-2

The german language package, could that be the problem?

I think a localization package should not have such a dramatic effect,
especially since we are not dealing with a major KDE upgrade, just a
change in the "third digit" of the version.

I would first try to make sure that you really did a complete upgrade of
all available package. (The "aptitude search" command I gave in my other
mail is OK to get an overview, but it might miss some more subtle issues
related to libraries.) I would do the following on a text terminal (as
root or with sudo):

invoke-rc.d kdm stop
aptitude update
aptitude dist-upgrade
invoke-rc.d kdm start

(You can use apt-get, wajig, etc. instead of aptitude if you prefer, of
 course, but make sure you do "dist-upgrade" and not just "upgrade".)

If it does not work after that then you might still have processes that
use old versions of upgraded libraries. The easiest way to rule that out
is to reboot and try again.

No luck? Check ~/.xsession-errors after KDE hangs. (I hope you can still
use CTRL-ALT-F1 to switch to a terminal when that happens.)

It would be fine, but I had no luck with that. The dist-upgrade runned, but had not to install any new packages. So it did not work after a reboot although. The .xsession-errors gave (me!) no hints at all:

Xsession: X session started for kristian at Do 24. Mai 23:28:22 CEST 2007
startkde: Starting up...
kbuildsycoca running...

Should I reinstall the complete kde packages?

Thanks Kristian

Reply to: