[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Resurrecting ancient IOMEGA ZIP drive



Hello folks,

for one last time I wanted to set in motion my old, parallel-port
IOMEGA Zip Drive to back up my stack of disks before I retire (read:
dump in the trash) the whole shebang for good.

I think the proper driver is ppa. I connected everything but nothing
happens. "Happens" in the sense that anything gets added in
the /dev/disks/ directory tree when I insert a disk in the drive. I
tried "rmmod"ing all parallel port-related modules and modprobing only
ppa, but no change. The module loaded without error though.

All this is sooo long ago, I really can't remember how it worked back
in the days of the 1.xx.yy kernel which is probably the last time I
used this thing.

I know there were two versions of the parallel-port ZIP, and my drive
is the older one.

Here's some modprobe output, if it is of any interest:

kir:/dev# modprobe -v ppa
insmod /lib/modules/2.6.18-4-k7/kernel/drivers/parport/parport.ko
insmod /lib/modules/2.6.18-4-k7/kernel/drivers/scsi/ppa.ko
ppa: Version 2.07 (for Linux 2.4.x)
pnp: Device 00:0a activated.
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378 (0x778), irq 7, dma 3
[PCSPP,TRISTATE,COMPAT,EPP,ECP,DMA]
kir:/dev#

Thanks,
--D.

Attachment: pgpm6XrE22nxk.pgp
Description: PGP signature


Reply to: