[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ./configure failed (twinkle)

Gerard Robin wrote:

> Hello,
> in /usr/local/src/twinkle-1.0.1/  I did ./configure and I got:
> ......
> checking for qt-mt >= 3.3.0 qt-mt < 4.0... yes
> ........
> checking value of $QTDIR... not set
> configure: error: Set $QTDIR to the Qt directory, eg. /usr/lib/qt3
> I set QTDIR at /usr and it was ok for tis error, but now ./configure says:
> checking for KDE... configure: error:
> in the prefix, you've chosen, are no KDE headers installed. This will
> fail. So, check this please and use another prefix!
> What can I do ?
> On the other hand I tried to make a .deb package and when I ran:
> debuild -us -uc I got:
> dpkg-checkbuilddeps : error: missing a line Package in the paragraph 2
> concerning the packages in the file control debuild: fatal error at line
> 987: You do not appear to have all build dependencies properly met,
> aborting. (Use -d flag to override.)
> If you have the pbuilder package installed you can run
> /usr/lib/pbuilder/pbuilder-satisfydepends as root to install the
> required packages, or you can do it manually using dpkg or apt using
> the error messages just above this message.
> My file control begin like this :
> Source: twinkle
> Section: comm
> Priority: optional
> Maintainer: foo <foo@bar.fr>
> Build-Depends: debhelper (>= 5), autotools-dev, libcommoncpp2-dev,
> libccrtp-dev, libzrtpcpp-dev, libqt3-mt-dev Standards-Version: 3.7.2
> Package: twinkle
> Architecture: amd64
> .........
> the paragraph 2 contains a line Package ...
> Can someone help me to succed at least one of the two cases.
> tia
Hi Gerard,
Do you have qt3-dev-tools libqt3-headers, libqt3-mt-dev, etc. installed. I
don't think Twinkle wants qt4.
Registerd Linux user #445917 at http://counter.li.org/

Reply to: