[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems after mixing Sarge and Etch

On Tue, 15 May 2007 10:41:55 +0200
Nick de Graeve <nick.degraeve@gmail.com> wrote:

> I inherited from my long gone predecessor the administration of an old
> server running Sarge. It is used for Bugzilla and Mantis and partly as
> webserver.
> I'm not very familiar with Debian, I'm a Mandriva man myself, but I'm
> the only one in the company left that has Linux experience. To keep
> the system up-to-date I do a "aptitude update && aptitude upgrade -y"
> each time I get a Security Advisory email .
> I think it was last week there were a whole bunch of packages that
> where held back. After some surfing I concluded that I had to do a
> "aptitude dist-upgrade" and indeed almost all packages could now be
> installed. Only a few weren't:
> moria:~# aptitude upgrade
> [...]
> The following packages have been kept back:
>  file libkrb53 libmagic1
> 0 packages upgraded, 0 newly installed, 0 to remove and 3 not
> upgraded.
> [..]
> However, since yesterday we're experiencing problems with PHP. It
> seems that with the previous updates the PHP module of Apache was
> uninstalled for some reason. The problem is I can't get it to install
> again:
> moria:~# aptitude install libapache-mod-php4
> Reading Package Lists... Done
> Building Dependency Tree
> Reading extended state information
> Initializing package states... Done
> Reading task descriptions... Done
> E: Unable to correct problems, you have held broken packages.
> E: Unable to correct dependencies, some packages cannot be installed
> E: Unable to resolve some dependencies!
> Some packages had unmet dependencies.  This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following packages have unmet dependencies:
>  libapache-mod-php4: Depends: libc6 (>= 2.3.6-6) but
> 2.3.2.ds1-22sarge6 is installed.
>                      Depends: libdb4.4 which is a virtual package.
>                      Depends: libkrb53 (>= 1.4.2) but 1.3.6-2sarge4
> is installed and it is kept back.
>                      Depends: libssl0.9.8 (>= 0.9.8c-1) which is a
> virtual package.
>                      Depends: apache-common (>= 1.3.34) but
> 1.3.33-6sarge3 is installed.
> That got me wondering...
> moria:~# cat /etc/apt/sources.list
> deb http://security.debian.org/ stable/updates main contrib
> deb http://ftp.nl.debian.org/debian sarge main contrib
> Yep, there's my problem (I guess): I've mixed Sarge with stable and
> stable is now Etch.
> So finally my questions:
> How can I salvage my system?
> Will replacing stable with sarge in the sources.list and do a
> "aptitude update" and "aptitude upgrade" (or "aptitude dist-upgrade")
> solve my problems?

That would be a downgrade; it's not, IIUC, officially supported and you
probably shouldn't do it unless you consider yourself an expert.

> Or should I upgrade the entire system to Etch?

Probably a good idea, since Etch is now stable; you'll get security
updates, and you'll have newer software. Of course, that could be a
problem for you; you may have to reconfigure things, etc.

> Nick.

Just my $.02,

mailmin.sourceforge.net - remote access via secure (OpenPGP) email
ssuds.sourceforge.net - A Simple Sudoku Solver and Generator

Reply to: