[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Please help - printing gone after upgrade to Etch

On Sat, May 05, 2007 at 01:40:50AM +0800, Uwe Heinz Rudi Dippel wrote:
> Sjoerd Hiemstra wrote:
> >> After upgrading to Etch, now printing (DeskJet 840C) is gone.
> >> Reason:
> >> % ls -l /dev/lp*
> >> ls: /dev/lp*: No such file or directory
> > 
> > I had something similar with my DeskJet 670C in Etch.
> > It appeared that /dev/lp0 had not been recognized for some reason,
> > therefore CUPS tried to print to /dev/other, which did not exist.
> > 
> > I could not be corrected in the CUPS printer administration, but I could
> > use the KDE printer setup (K > System > Printers) to manually set the
> > output device to /dev/lp0, which solved it.
> It is so sad. Theoretically, Debian is my favourite distro, and I wonder why practically, it is at times so 'could-not-care-less'. :(
> I do bother and file bug reports. Only to see them being closed with a workaround or simply unattended to.
> This is a server, no GUI, worked with Sarge. Why should it not
continue working with Etch ? Yes, it does, with 'modprobe lp'. The
maintainer of udev suggested CUPS, then to 'blame the maintainer of
lpr'. Neither is a solution, but bug report 'closed'. 

why should the udev developer fix a bug in lpr? it is not up to udev,
as I understand it, to figure out which modules to insert, just to
make sure the device nodes get created properly when it does
happen. The need for an lp module to be inserted should fall to the
package that handles the parallel printer support.



Attachment: signature.asc
Description: Digital signature

Reply to: