[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Please help - printing gone after upgrade to Etch

Title: Re: Please help - printing gone after upgrade to Etch

Sjoerd Hiemstra wrote:

>> After upgrading to Etch, now printing (DeskJet 840C) is gone.
>> Reason:
>> % ls -l /dev/lp*
>> ls: /dev/lp*: No such file or directory
> I had something similar with my DeskJet 670C in Etch.
> It appeared that /dev/lp0 had not been recognized for some reason,
> therefore CUPS tried to print to /dev/other, which did not exist.
> I could not be corrected in the CUPS printer administration, but I could
> use the KDE printer setup (K > System > Printers) to manually set the
> output device to /dev/lp0, which solved it.

It is so sad. Theoretically, Debian is my favourite distro, and I wonder why practically, it is at times so 'could-not-care-less'. :(
I do bother and file bug reports. Only to see them being closed with a workaround or simply unattended to.
This is a server, no GUI, worked with Sarge. Why should it not continue working with Etch ? Yes, it does, with 'modprobe lp'. The maintainer of udev suggested CUPS, then to 'blame the maintainer of lpr'. Neither is a solution, but bug report 'closed'. What a silly bloat, when Aunty Tilly needs to install CUPS or KDE to bring along an application that - in case - issues a modprobe ?!
Worse: Sarge had /dev/lp0 and *was* working. Can we not expect to have a working system after the upgrade ? Were we not encouraged to file bugs against update problems ? And losing the device of a parallel printer can not be filed under 'unfortunate circumstances', mitigated by the fact that CUPS and KDE eventually are well enough written to rectify the problem without user intervention.


Reply to: